Actualizar de Linux Mint 16 «Petra» a Linux Mint 17 «Qiana» en línea de comandos

Hoy ha sido liberada oficialmente la version Linux Mint 17 con nombre Qiana. Está basada en Ubuntu 14.04 LTS llamada Trusty Tahr que tendrá soporte hasta abril del 2019. Linux Mint Qiana también será una LTS, lo cual será apreciado por muchos usuarios por la estabilidad que dará.

Antes de nada, conviene hacer un backup de los datos importantes que tengamos guardados en el sistema. La actualización es bastante segura, pero nunca se sabe.

Para actualizar desde Linux Mint 16 «Petra» a Linux Mint 17 «Qiana», seguid estos pasos:

Abrimos una terminal de comandos.

Escribimos los comandos siguientes. Son para reemplazar los nombres de la versión actual de Linux Mint y Ubuntu por los nuevos en los archivos de repositorios de apt-get:

$ find /etc/apt/sources.list.d/* | xargs sudo perl -pi -e 's/petra/qiana/g'
$ find /etc/apt/sources.list.d/* | xargs sudo perl -pi -e 's/saucy/trusty/g'

Una vez hecho el cambio, actualizamos la lista de paquetes:

$ sudo apt-get update

y hacemos una actualización de la distribución:

$sudo apt-get -f dist-upgrade

Tan sencillo como esto 🙂

6 Comments
  • rodrigo
    marzo 6, 2015

    como se hace eso de abrir terminal de comando???’

    • Gustavo Moreno
      marzo 6, 2015

      En los menús de muchos escritorios, hay un programa llamado Terminal, con el que se abre un emulador de la línea de comandos.

  • Fernando
    febrero 4, 2016

    amigo gracias …..excelente

  • Bertholdo
    febrero 8, 2016

    Hola.
    Instalé Linux Mint 17.3 en PC con motherboard MSI 760GM (video onboard Ati 3000), modo dual con un windows.
    He aplicado hasta los Updates Nivel 2.
    Desde el Gestor (gráfico) de Actualizaciones: ¿Es aconsejable actualizar hasta los Updates de Nivel 3, y mantener activo que se reemplacen paquetes viejos por nuevos que lleguen?

    Si se efectúa la labor desde Terminal:
    ¿Los comandos: sudo apt-get update && sudo apt-get upgrade , actualizarían todos los Updates disponibles, hasta los de Nivel 5??
    ¿Cómo se puede dosificar esto desde Terminal, para que solo actualice los Updates de determinado Nivel, ejemplo hasta los de Nivel 3 ó 2?

  • Jorge
    agosto 10, 2017

    soy reciente usuario de linux mint 16 y quise cambiar a Linux Mint 17 Qiana

    al ingresar las instrucciones a la consola me sale:
    $: command not found

    ¿cuál es el problema?

    • Gustavo Moreno
      agosto 10, 2017

      Se me ocurre que tu sistema no tenga instalado o bien el paquete findutils (que contienen find y xargs) o bien no tenga instalado el Perl.